Modellbahn Simlinger

ROLLENDES GUT

DOKUMENTATION

21.01.12 Die Tücke mit den Weichendecodern

In den letzten beiden Wochen hat mich eher die Elektronik beschäftigt.
Nach dem Anschluss mehrer Weichenservos von CT haben diese plötzlich nur noch teilweise funktioniert.
Ein Fehler in den Sevos und der Software konnte nach Test ausgeschlossen werden, der Fehler lag in den Decodern
Herr Tran als Erzeuger der Decoder hat sich der Sache angenommen und festgestellt, dass von der LENZ-Zentrale das Steuerseignal nicht einwandfrei an die 4-fach Weichendecoder übermittet wird.
Nach dem Auflöten von zwei Keramik-Filtern war die Sache geritzt, ich habe ca 20 Servo-Module parallel in die Anlage hängen könne, alle haben die Signale einwandfrei erhalten. 

Das Lesezeichen mit der MM-Skala verdeutlicht die Grössenvehältnisse.
Die Keramikfilter sind knapp einen mm lang und ca 1/2 mm breit und mussten jeweils auf ein bestehendes Element (so wie die direkt hinter den Filtern noch sichtabr sind) "Huckepack" aufgelötet werden.
Da wird das Löten spannend...
Herr Tran ist zu mir gekommen und hat hier die Filter aufgelötet.
An dieser Stelle einen ausdrücklichen Dank an Herrn Tran für seine unkomplizierte Einsatzbereitschaft! 

Die ausgebauten Decoder


Die Decoder sind rd 40 / 40 mm gross...

Die Tücke des Anlaufstroms
Nachdem in allen 29 Decodern die beiden Keramikfilter aufgelötet waren, habe ich die ersten 9 Decoder eingebaut.
Alle haben brav mit der Diode geblinkt, alles bestens.
Dann habe ich die Servos schrittweise angeschlossen, momentan insgesamt 32 Sück, alles bestens, auch die Zugsteuerung hat bestens funktioniert.

Die Ernüchterung kam nach dem nächsten Start der Anlage: Kurzschlussmeldung, kein Betrieb der Anlage möglich.
Nach einiger Fehlersuche konnte ich den Fehler auf die Anzahl der ageschlossenen Servos eingrenzen.

Mit 32 Servos gleichzeitig angesteckt ist ein Start der Digitalzentrale nicht möglich, es gibt eine Kurzschlussmeldung, bzw eine Überlastung der Zentrale beim Einschalten.
Nehme ich 8 Servos weg, kann ich das Programm bzw. die Zentrale starten.
 
Die LENZ-Zentrale LVZ 100 schafft 5A Dauerstrom, der Überlastungsschutz setzt bei ca. 100 ms ein.

Offenbar fliesst beim Einschalten mehr als 5A länger 100 ms, was pro Servo (vereinfacht, und wenn alle anderen Verbraucher Null beim Einschalten "ziehen") ca. 200 mA Anlaufstrom bedeuten würde.

Beim Einschalten "Zucken" alle Servos kurz auf (übrigens auch bei den ESU-Decodern) und verbrauchen kurzfristig viel Strom.

Dies will Herr Tran so lösen, dass er abhängig vom Wert der CV1 jedes Decoders die Einschaltzeit zeitlich verzögern will, sodass die Weichendecoder nacheinaner "starten" und so nur noch sehr wenige Servos gleichzeitig Strom ziehen können.

Ich bin gespannt, wie das gelingt. So kann ich mir jedenfalls eine eigene Stromversorgung für die Servos sparen, wobei ich insgesamt ca 240 Servos im Vollausbau der Anlage haben werde.



Weiter im Jahr 2011 .....